Device Payment Processing Degradation

Incident Report for Rainforest

Resolved

This incident has been resolved.
Posted May 03, 2026 - 23:31 UTC

Monitoring

Device payments were in degraded state from 5:25pm - 5:30pm EST. Device payments have recovered. We will be monitoring for any further issues.
Posted May 03, 2026 - 21:52 UTC

Investigating

We are currently investigating this issue.
Posted May 03, 2026 - 21:40 UTC
This incident affected: Payment Processing (EMV Device Payments).