Disruption in payment processing

Incident Report for Rainforest

Resolved

This incident has been resolved.
Posted Nov 05, 2024 - 18:04 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 05, 2024 - 16:54 UTC

Monitoring

From approximately 11:42 to 11:48 EST and 11:51 to 11:54 EST, payment processing services were disrupted. Engineers have identified and remediated the root cause of the disruption. We are continuing to monitor systems to ensure complete recovery.
Posted Nov 05, 2024 - 16:53 UTC
This incident affected: Payment Processing (Credit Card Payments, ACH Payments) and Management Portal.