Elevated declines due to sporadic payment network issues

Incident Report for Rainforest

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 20:26 UTC

Monitoring

Upstream network issues have been resolved. Only a small number of payin attempts were ultimately impacted. Engineers continue to monitor closely.
Posted Mar 31, 2025 - 19:44 UTC

Identified

We have identified sporadic network issues in upstream payment connections, impacting <2% of payin attempts.
Posted Mar 31, 2025 - 19:05 UTC
This incident affected: Payment Processing (Credit Card Payments).